--- a/QTfrontend/CMakeLists.txt Mon Dec 17 00:43:52 2012 +0100
+++ b/QTfrontend/CMakeLists.txt Tue Dec 18 03:07:45 2012 +0100
@@ -136,6 +136,12 @@
set(hwfr_rez hedgewars.qrc)
+if(BUILD_ENGINE_LIBRARY)
+ add_definitions(-DHWLIBRARY)
+ set(HW_LINK_LIBS hwengine ${HW_LINK_LIBS})
+ link_directories(${EXECUTABLE_OUTPUT_PATH})
+endif()
+
qt4_add_resources(hwfr_rez_src ${hwfr_rez})
qt4_wrap_cpp(hwfr_moc_srcs ${hwfr_moc_hdrs})
@@ -160,12 +166,6 @@
endif()
endif()
-if(BUILD_ENGINE_LIBRARY)
- add_definitions(-DHWLIBRARY)
- set(HW_LINK_LIBS hwengine ${HW_LINK_LIBS})
- link_directories(${EXECUTABLE_OUTPUT_PATH})
-endif()
-
#when debugging, always prompt a console to see fronted messages
#TODO: check it doesn't interfere on UNIX
if(CMAKE_BUILD_TYPE MATCHES "RELEASE")