--- a/hedgewars/CMakeLists.txt Thu Feb 28 23:02:12 2013 +0100
+++ b/hedgewars/CMakeLists.txt Thu Feb 28 23:05:07 2013 +0100
@@ -91,7 +91,7 @@
)
if(${BUILD_ENGINE_LIBRARY})
- message(WARNING "Engine will be built as library (experimental)")
+ message(${WARNING} "Engine will be built as library (experimental)")
list(APPEND pascal_flags "-dHWLIBRARY")
# create position independent code, only required for x68_64 builds, similar to -fPIC
@@ -160,7 +160,7 @@
list(APPEND pascal_flags "-k${PNG_LIBRARY}")
endif()
else()
- message(WARNING "Screenshots will be in BMP format because libpng was not found")
+ message(${WARNING} "Screenshots will be in BMP format because libpng was not found")
endif()
else()
message(STATUS "Screenshots will be in BMP format per user request")
@@ -200,7 +200,7 @@
list(APPEND pascal_flags "-k${FFMPEG_LIBAVCODEC}" "-k${FFMPEG_LIBAVFORMAT}" "-k${FFMPEG_LIBAVUTIL}")
ENDIF()
else()
- message(WARNING "Could NOT find FFMPEG/LibAV, video recording will be disabled")
+ message(${WARNING} "Could NOT find FFMPEG/LibAV, video recording will be disabled")
endif()
else()
message(STATUS "Video recording disabled by user")