--- a/hedgewars/CMakeLists.txt Tue Jul 07 21:48:55 2009 +0000
+++ b/hedgewars/CMakeLists.txt Tue Jul 07 22:02:13 2009 +0000
@@ -88,10 +88,10 @@
message("Minimum required version of FreePascal is 2.2.0")
else (fpc_ver LESS "020200")
set(pascal_compiler ${fpc_executable})
- if( NOT CMAKE_BUILD_TYPE OR CMAKE_BUILD_TYPE MATCHES "Release")
+ if(NOT CMAKE_BUILD_TYPE OR CMAKE_BUILD_TYPE MATCHES "Release")
set(pascal_compiler_flags ${noexecstack_flags} "-B" "-FE../bin" "-Fl../bin/" "-Cs2000000" "-vwi" "-O2" "-Xs" ${hwengine_project})
else()
- set(pascal_compiler_flags ${noexecstack_flags} "-B" "-FE../bin" "-Fl../bin/" "-Cs2000000" "-vwi" "-O-" "-gl" ${hwengine_project})
+ set(pascal_compiler_flags ${noexecstack_flags} "-B" "-FE../bin" "-Fl../bin/" "-Cs2000000" "-vwi" "-O-" "-gl" "-dDEBUGFILE" ${hwengine_project})
endif()
endif (fpc_ver LESS "020200")
endif (fpc_version)