share/hedgewars/Data/Fonts/CMakeLists.txt
branchhedgeroid
changeset 15515 7030706266df
parent 9994 8455993a7a1b
--- a/share/hedgewars/Data/Fonts/CMakeLists.txt	Sun Oct 28 15:18:26 2012 +0100
+++ b/share/hedgewars/Data/Fonts/CMakeLists.txt	Fri Dec 06 22:20:53 2019 +0100
@@ -1,4 +1,26 @@
-install(FILES
-	DejaVuSans-Bold.ttf
-    wqy-zenhei.ttc
-	DESTINATION ${SHAREPATH}Data/Fonts)
+set(FONTFILES
+    DejaVuSans-Bold.ttf
+    wqy-zenhei.ttc)
+
+if (FONTS_DIRS)
+    foreach(fontfile ${FONTFILES})
+        set(missing 1)
+        foreach(fontdir ${FONTS_DIRS})
+            if (EXISTS "${fontdir}/${fontfile}")
+                message(STATUS "Fonts: Found ${fontfile} in ${fontdir}")
+                set(missing 0)
+                break()
+            endif()
+        endforeach(fontdir)
+        if(missing)
+            set(MISSINGFONTFILES ${MISSINGFONTFILES} ${fontfile})
+            message(STATUS "Fonts: Could not find ${fontfile}, it will be installed")
+        endif()
+    endforeach(fontfile)
+else()
+    set(MISSINGFONTFILES ${FONTFILES})
+endif()
+
+if (MISSINGFONTFILES)
+    install(FILES ${MISSINGFONTFILES} DESTINATION ${SHAREPATH}Data/Fonts)
+endif()