--- a/CMakeLists.txt Wed Mar 31 22:02:12 2010 +0000
+++ b/CMakeLists.txt Wed Mar 31 22:54:28 2010 +0000
@@ -71,10 +71,14 @@
#create universal binaries only when it's time to bundle the application, also build server
IF(BUNDLE)
- set(WITH_SERVER false)
+ set(WITH_SERVER true)
if(NOT minimum_macosx MATCHES "10.6")
set(CMAKE_C_COMPILER "gcc-4.0")
set(CMAKE_CXX_COMPILER "g++-4.0")
+ else()
+ if(current_macosx_version MATCHES "10.6")
+ set(CMAKE_OSX_ARCHITECTURES "x86_64")
+ endif()
endif()
ELSE()
if(current_macosx_version MATCHES "10.6")