project_files/hwc/CMakeLists.txt
branchui-scaling
changeset 15663 d92eeb468dad
parent 15362 c8f37fc9c266
child 15555 107170c05bac
--- a/project_files/hwc/CMakeLists.txt	Wed Jul 31 23:14:27 2019 +0200
+++ b/project_files/hwc/CMakeLists.txt	Fri Jul 03 23:51:47 2020 +0200
@@ -1,6 +1,5 @@
 #the usual set of dependencies
 find_package(OpenGL REQUIRED)
-find_package(GLEW REQUIRED)
 find_package(SDL2 REQUIRED)
 find_package(SDL2_mixer 2 REQUIRED)
 find_package(SDL2_net 2 REQUIRED)
@@ -8,7 +7,6 @@
 find_package(SDL2_ttf 2 REQUIRED)
 
 #compile our rtl implementation
-include_directories(${GLEW_INCLUDE_DIR})
 include_directories(${CMAKE_CURRENT_SOURCE_DIR}/rtl)
 include_directories(${PHYSFS_INCLUDE_DIR})
 include_directories(${PHYSLAYER_INCLUDE_DIR})
@@ -74,6 +72,9 @@
 if(GL2)
     set(pas2c_args ${pas2c_args} -d GL2)
 endif()
+if(APPLE)
+    set(pas2c_args ${pas2c_args} -d DARWIN)
+endif()
 
 if(LIBAV_FOUND)
     add_subdirectory(${CMAKE_SOURCE_DIR}/hedgewars/avwrapper ${CMAKE_CURRENT_BINARY_DIR}/avwrapper)
@@ -115,7 +116,6 @@
                                 ${SDL2_NET_LIBRARIES}
                                 ${SDL2_IMAGE_LIBRARIES}
                                 ${SDL2_TTF_LIBRARIES}
-                                ${GLEW_LIBRARY}
                                 physfs
                                 physlayer
                                 m