CMakeLists.txt
branchtransitional_engine
changeset 16038 d903f8d2395a
parent 16023 0fd23fc57947
--- a/CMakeLists.txt	Wed Sep 18 14:10:51 2024 +0200
+++ b/CMakeLists.txt	Wed Nov 20 21:37:47 2024 +0100
@@ -269,7 +269,8 @@
 #rust libraries
 add_subdirectory(tools/corrosion)
 corrosion_import_crate(MANIFEST_PATH rust/lib-hwengine-future/Cargo.toml)
-
+corrosion_install(TARGETS hwengine_future EXPORT hwengine_future_install_target)
+install(EXPORT hwengine_future_install_target DESTINATION ${target_library_install_dir})
 
 #maybe this could be merged inside hedgewars/CMakeLists.txt
 if(BUILD_ENGINE_C)