--- a/project_files/hwc/CMakeLists.txt Thu Apr 21 11:54:21 2016 -0400
+++ b/project_files/hwc/CMakeLists.txt Thu Apr 21 11:55:36 2016 -0400
@@ -6,9 +6,6 @@
find_package(SDL2_net REQUIRED)
find_package(SDL2_image REQUIRED)
find_package(SDL2_ttf REQUIRED)
-if(BUILD_ENGINE_JS)
- find_package(Emscripten REQUIRED)
-endif()
#compile our rtl implementation
include_directories(${GLEW_INCLUDE_DIR})
@@ -81,13 +78,12 @@
add_definitions(-DPAS2C)
add_definitions(-Werror=incompatible-pointer-types)
+add_executable(hwengine WIN32 ${engine_sources})
+
if(BUILD_ENGINE_JS)
- #hijack the c compiler with emscripten
- set(CMAKE_C_COMPILER ${EMSCRIPTEN_EXECUTABLE})
+ set_target_properties(hwengine PROPERTIES SUFFIX ".html")
endif()
-add_executable(hwengine WIN32 ${engine_sources})
-
target_link_libraries(hwengine fpcrtl
${LUA_LIBRARY}
${OPENGL_LIBRARY}