--- a/misc/liblua/CMakeLists.txt Wed Feb 17 19:50:22 2010 +0000
+++ b/misc/liblua/CMakeLists.txt Wed Feb 17 20:03:25 2010 +0000
@@ -1,8 +1,24 @@
+file(GLOB lua_src *.c *.h)
+set(LIBRARY_OUTPUT_PATH ${EXECUTABLE_OUTPUT_PATH})
+
IF(APPLE)
- file(GLOB lua_src *.c *.h)
set(CMAKE_OSX_ARCHITECTURES "x86_64;i386;ppc7400")
- set (build_type STATIC)
+ set(build_type STATIC)
add_definitions(-DLUA_USE_LINUX)
- add_library (lua ${build_type} ${lua_src})
ENDIF(APPLE)
+
+IF(WIN32)
+ set(build_type SHARED)
+ add_definitions(-DLUA_BUILD_AS_DLL)
+ENDIF(WIN32)
+
+add_library (lua ${build_type} ${lua_src})
+
+if(WIN32)
+ SET_TARGET_PROPERTIES(lua PROPERTIES PREFIX "")
+ install(TARGETS lua DESTINATION ${target_dir})
+endif(WIN32)
+
+
+