author | koda |
Fri, 12 Nov 2010 22:47:13 +0100 | |
changeset 4281 | e033cf015b2c |
parent 3948 | 24daa33a3114 |
child 4446 | 3093791dc620 |
permissions | -rw-r--r-- |
3829 | 1 |
/* |
2 |
* Hedgewars-iOS, a Hedgewars port for iOS devices |
|
3 |
* Copyright (c) 2009-2010 Vittorio Giovara <vittorio.giovara@gmail.com> |
|
4 |
* |
|
5 |
* This program is free software; you can redistribute it and/or modify |
|
6 |
* it under the terms of the GNU General Public License as published by |
|
7 |
* the Free Software Foundation; version 2 of the License |
|
8 |
* |
|
9 |
* This program is distributed in the hope that it will be useful, |
|
10 |
* but WITHOUT ANY WARRANTY; without even the implied warranty of |
|
11 |
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the |
|
12 |
* GNU General Public License for more details. |
|
13 |
* |
|
14 |
* You should have received a copy of the GNU General Public License |
|
15 |
* along with this program; if not, write to the Free Software |
|
16 |
* Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. |
|
17 |
* |
|
18 |
* File created on 08/04/2010. |
|
19 |
*/ |
|
20 |
||
3547 | 21 |
|
22 |
#import <Foundation/Foundation.h> |
|
23 |
||
24 |
||
25 |
@interface UIImage (extra) |
|
26 |
||
27 |
-(UIImage *)scaleToSize:(CGSize) size; |
|
28 |
-(UIImage *)mergeWith:(UIImage *)secondImage atPoint:(CGPoint) secondImagePoint; |
|
3948
24daa33a3114
some rethinking of initial menu presentation and initial orientation (also merging images should be threadsafe now)
koda
parents:
3910
diff
changeset
|
29 |
-(UIImage *)mergeWith:(UIImage *)secondImage atPoint:(CGPoint) secondImagePoint ofSize:(CGSize) resultingSize; |
3547 | 30 |
-(id) initWithContentsOfFile:(NSString *)path andCutAt:(CGRect) rect; |
3621 | 31 |
-(UIImage *)cutAt:(CGRect) rect; |
3547 | 32 |
-(UIImage *)convertToGrayScale; |
3903 | 33 |
-(UIImage *)convertToNegative; |
3547 | 34 |
-(UIImage *)maskImageWith:(UIImage *)maskImage; |
35 |
-(UIImage *)makeRoundCornersOfSize:(CGSize) sizewh; |
|
3910
dd47efbdec46
move all preview drawing code into its own class (for a simplified and more readable MapConfigViewController)
koda
parents:
3903
diff
changeset
|
36 |
+(UIImage *)whiteImage:(CGSize) ofSize; |
3547 | 37 |
|
38 |
@end |