--- a/hedgewars/CMakeLists.txt Fri Jun 08 02:52:35 2012 +0400
+++ b/hedgewars/CMakeLists.txt Mon Jun 11 17:56:10 2012 +0400
@@ -172,13 +172,15 @@
if(${PNG_FOUND})
message(STATUS "PNG screenshots enabled (library found at ${PNG_LIBRARY})")
set(pascal_flags "-dPNG_SCREENSHOTS" ${pascal_flags})
- if(APPLE) # need to explictly link with the static lib
+ if(APPLE) # need to explictly link with the static lib -- maybe windows too?
string(REGEX REPLACE "(.*)libpng.*" "\\1" PNG_LIBDIR "${PNG_LIBRARY}")
set(pascal_flags "-k${PNG_LIBDIR}/libpng.a" ${pascal_flags})
endif()
else()
message(STATUS "PNG library not found, switching to screenshots in BMP format")
endif()
+else()
+ message(STATUS "PNG screenshots disabled per user request, using BMP format")
endif()
set(fpc_flags ${noexecstack_flags} ${pascal_flags} ${hwengine_project})