--- a/CMakeLists.txt Wed Mar 03 18:47:02 2010 +0000
+++ b/CMakeLists.txt Wed Mar 03 23:04:24 2010 +0000
@@ -53,6 +53,10 @@
set(minimum_macosx ${current_macosx_version})
endif()
+ if (minimum_macosx LESS "10.4")
+ set(FATAL "Hedgewars is not supported for pre-10.4 systems")
+ endif()
+
if(current_macosx_version MATCHES "10.6")
set(CMAKE_OSX_ARCHITECTURES "x86_64")
endif()
@@ -60,7 +64,9 @@
#create universal binaries only when it's time to bundle the application, also build server
IF(BUNDLE)
set(WITH_SERVER false)
- if(minimum_macosx NOT MATCHES "10.6")
+ if(NOT minimum_macosx MATCHES "10.6")
+ set(CMAKE_C_COMPILER "gcc-4.0")
+ set(CMAKE_CXX_COMPILER "g++-4.0")
set(CMAKE_OSX_ARCHITECTURES "i386;ppc7400")
endif()
ENDIF()