misc/libphysfs/CMakeLists.txt
changeset 9125 c542f6e3a133
parent 9117 1bed4aee19e0
child 9126 63bf1f4f40f8
child 9127 e350500c4edb
child 9158 b4d8baf4669a
--- a/misc/libphysfs/CMakeLists.txt	Tue Jun 04 23:58:42 2013 +0400
+++ b/misc/libphysfs/CMakeLists.txt	Tue Jun 04 22:08:17 2013 +0200
@@ -35,6 +35,15 @@
 include(CheckCSourceCompiles)
 
 
+# 32bit platforms won't link unless this is set
+# although Windows doesn't like it
+if(NOT WINDOWS)
+    if(CMAKE_SIZEOF_VOID_P LESS 8)
+        add_definitions(-DPHYSFS_NO_64BIT_SUPPORT=1)
+    endif(CMAKE_SIZEOF_VOID_P LESS 8)
+endif(NOT WINDOWS)
+
+
 if(MACOSX)
     # Fallback to older OS X on PowerPC to support wider range of systems...
     if(CMAKE_OSX_ARCHITECTURES MATCHES ppc)