--- a/QTfrontend/CMakeLists.txt Tue Dec 18 12:04:17 2012 +0100
+++ b/QTfrontend/CMakeLists.txt Wed Dec 19 18:17:23 2012 +0100
@@ -138,11 +138,11 @@
if(BUILD_ENGINE_LIBRARY)
add_definitions(-DHWLIBRARY)
- if (WIN32)
- set (hwlibname ${EXECUTABLE_OUTPUT_PATH}/hwLibrary.dll)
- else (WIN32)
+ if (APPLE)
set (hwlibname hwengine)
- endif (WIN32)
+ else (APPLE)
+ set (hwlibname "${EXECUTABLE_OUTPUT_PATH}/${CMAKE_SHARED_LIBRARY_PREFIX}hwLibrary${CMAKE_SHARED_LIBRARY_SUFFIX}")
+ endif (APPLE)
set(HW_LINK_LIBS ${hwlibname} ${HW_LINK_LIBS})
link_directories(${EXECUTABLE_OUTPUT_PATH})
endif()