--- a/hedgewars/CMakeLists.txt Mon Feb 24 13:41:32 2014 -0500
+++ b/hedgewars/CMakeLists.txt Wed Feb 26 00:28:27 2014 +0400
@@ -198,9 +198,11 @@
#SOURCE AND PROGRAMS SECTION
if(BUILD_ENGINE_LIBRARY)
message("***Engine will be built as library (experimental)***")
- if(APPLE AND ${current_macosx_version} VERSION_GREATER "10.5")
- # due to compiler/linker issues on Max OS X 10.6 -k-no_order_inits is needed to avoid linking fail
- add_flag_prepend(CMAKE_Pascal_FLAGS "-k-no_order_inits")
+ if(APPLE)
+ if (${current_macosx_version} VERSION_GREATER "10.5")
+ # due to compiler/linker issues on Max OS X 10.6 -k-no_order_inits is needed to avoid linking fail
+ add_flag_prepend(CMAKE_Pascal_FLAGS "-k-no_order_inits")
+ endif()
endif()
#workaround for missing <TARGET> support during object generation