project_files/hwc/CMakeLists.txt
branchtransitional_engine
changeset 16009 7544a7d7c819
parent 15962 4013354585be
--- a/project_files/hwc/CMakeLists.txt	Tue Sep 05 17:02:08 2023 +0200
+++ b/project_files/hwc/CMakeLists.txt	Fri Jan 19 13:07:22 2024 +0100
@@ -6,6 +6,8 @@
 find_package(SDL2_image 2 REQUIRED)
 find_package(SDL2_ttf 2 REQUIRED)
 
+corrosion_import_crate(MANIFEST_PATH "${CMAKE_SOURCE_DIR}/rust/lib-hwengine-future/Cargo.toml")
+
 #compile our rtl implementation
 include_directories(${CMAKE_CURRENT_SOURCE_DIR}/rtl)
 include_directories(${PHYSFS_INCLUDE_DIR})
@@ -119,6 +121,7 @@
                                 physfs
                                 physlayer
                                 m
+                                hwengine_future
                                 ${HW_LINK_LIBS}
                                 #TODO: add other libraries
                             )